読者です 読者をやめる 読者になる 読者になる

mazeltov7のweb断片

備忘録的なテキトーなことを書きます。間違ってたり、ツッコミあればお願いします。

macでphpを5.5から5.6にする

やること

brewphpを5.5から5.6にする

やったこと

phpenv入ってなかったので普通にbrewでよろしくいれる。
まず諸々最新にする。

$ brew update
$ brew upgrade

入れる。

$ brew install php56
Error: Cannot install josegonzalez/php/php56 because conflicting formulae are installed.
php55: because different php versions install the same binaries.
Please `brew unlink php55` before continuing.

おこられたので、unlinkして入れる

$ brew unlink php55
$ brew install php56
$ php -v

以上

PS ちなみにこれ参考になるやも
brewで入れたphp諸々の在処 - mazeltov7のweb断片